Choose a Version of Bloodcraft 5

Bloodcraft 1.12.2 
Bloodcraft 5

Should Work with latest forge 1.12.2 version or lower.

Mobirise
Bloodcraft 5 1.16.5 1.9.9
Bloodcraft 5

Should Work with latest forge 1.16.5 version or lower. 

Mobirise
Bloodcraft 1.15.2 1.9.9
Bloodcraft 5

Should Work with latest forge 1.15.2 version or lower.

Mobirise
Bloodcraft 5 1.14.4 1.9.8
Bloodcraft 5

Should Work with latest forge 1.14.4 version or lower. 

Mobirise

© Copyright 2025 Solarflare Studios. All Rights Reserved.

Website was built with Mobirise